User manual

This user manual provides detailed information on installing and using XPFlightPlanner, the X-Plane flight planner and generator.

The manual is still aligned to version 4.1, it will be updated for version 4.2 soon ! Thanks for your patience 😀.

Introduction

XPFlightplanner is a sim flight plan generator application compatible with X-Plane. It has been carefully designed to be intuitive, allowing flightsim enthusiasts to easily create flight plans from one airport to another with just a few simple clicks.

XPFlightPlanner uses X-Plane’s native file format *.fms to store and load flight plans.

Remember, this tool must not be used for real world aviation but for simulation purpose only!

Initial setup

XPFlightPlanner can be installed on Windows and Mac OS X, it requires either:

  • Microsoft Windows (10+) on an Intel 64 bit computer
  • or Apple Mac OS X (11+) on an Apple Silicon (M1, M2) or Intel Mac.

Installer files can be  downloaded from our download page.

Installation on Windows

To install XPFlightPlanner on Microsoft Windows, simply follow these steps:

  1. Download the installer
  2. Execute the installer and follow instructions
  3. Launch XPFlightPlanner from the  Start menu

By default XPFlightPlanner is installed in C:\Program Files\XPFlightPlanner.

Installation on Mac

To install XPFlightPlanner on Apple Mac OS X, simply follow these steps:

  1. Download the image file (dmg)
  2. Open the image file and copy XPFlightPlanner to /Applications folder
  3. Eject the disk image and launch XPFlightPlanner by double clicking on it

Activate with your serial number

To register your copy of XPFlightPlanner, follow these simple steps:

  1. Go to the “Help” menu, then select “Register your license”
  2. Copy and paste your email and serial number from the order email into the registration dialog to ensure accuracy and prevent any typos
  3. Click on the “Activate” button
XPFlightPlanner license
Activate your license

If you didn’t receive your serial number, please check your email inbox and spam folder. The email is sent automatically after the purchase is completed.

By default, you can activate XPFlightPlanner on up to 5 computers that you own. If you need more activation slots for your personal use, please contact us.

Once the activation is complete, XPFlightPlanner will unlock the limitation of 5 waypoints, allowing you to fully experience the full capabilities of the software.

Select the navigation database

To use XPFlightPlanner, you’ll need access to X-Plane’s world navigation database. You have two options for the database source: either downloading the database from the internet (which is stored on GitHub servers), or importing the navigation database from your local X-Plane installation.

Upon first launch, the “Navigation database” dialog will appear, allowing you to choose between downloading the database from the internet (which is hosted on GitHub servers), or loading the database from your local X-Plane installation. You can also access this dialog at any time by selecting “Select navigation database” from the “Edit” menu.

XPFlightPlanner navigation database
Select the navigation database
  • If you choose to download the database from the internet, select the “Use database from server” option and click the “Download” button. The download process can take up to a minute, depending on your network speed and the server’s conditions. Once the database has been successfully downloaded, it will be stored on your computer in an optimized binary format. XPFlightPlanner will use this same database each time it is started, unless you update and download a new version.
  • Alternatively, you can choose to import the database from your X-Plane installation by selecting “Use X-Plane database” and then clicking “Import from X-Plane.” This process may take up to 1 minute, depending on the speed of your computer. After complete, the binary optimized database will be loaded every time you start XPFlightPlanner.

In order to ensure that XPFlightPlanner is using the most up-to-date navigation database, you’ll need to either download or import the database again whenever the X-Plane data cycle is updated.

To use a custom navigation database in XPFlightPlanner, such as one provided by Navigraph, simply select the option “Use custom data” in the “Navigation database” dialog, and then load the data by clicking the “Import from X-Plane” button. This will import the custom database into XPFlightPlanner’s binary optimized format. Note that you will need to re-import the custom database each time your provider updates the data cycle.

To load a custom navigation database, ensure that the custom data is located in the <X-Plane>/Custom Data directory and contains the following files:

  • earth_awy.dat,
  • earth_fix.dat,
  • earth_nav.dat,
  • CIFP directory.

Note: X-Plane distributes its database under the GPL license. In our GitHub repository which is also made available to the public under the GPL license, you will find the source code for the command line tool that converts the X-Plane database into the binary optimized format used by XPFlightPlanner and the corresponding binary file.

Using XPFlightPlanner

User interface overview

When you launch XPFlightPlanner the main window will appear, displaying an empty flight plan document. This window consists of four main sections: a map, a flight plan table, a list of available points (corresponding to the navigation database), and a panel that displays details of the selected item (point or route).

XPFlightPlanner interface overview

The main window also features a toolbar at the top of the screen, which provides quick access to frequently used actions. All actions can also be found in the top menu. If you wish to hide either the map or the flight plan table, you can use the relevant buttons on the right toolbar or choose the appropriate option in the “View” menu.

Generate a new flight plan

XPFlightPlanner allows you to create flight plans either automatically with the flight plan generator or manually. You can also modify an automatically generated flight plan as needed.

Generate flight plan automatically

XPFlightPlanner has a route finder that can generate the best route from an airport to another.

To generate a flight plan in XPFlightPlanner, you need to have at least two waypoints in your flight plan. The first waypoint should represent your departure point and the second your arrival.

Once you have added these two waypoints, you can either click on the generator button  or go to the “Flight plan” menu and select “Generator”. The application will then open the route finder dialog which gives a general overview of the flight: departure, arrival and approximate distance.

In dialog, you can configure the performance parameters for your aircraft. To do this, select your desired climb performance, including the climb speed (knots) and rate (feet/min). Next, specify the cruise altitude (feet or Flight Level) and speed (knots or Mach). Finally, choose your preferred descent speed and rate. These performance settings are saved and will be remembered for future use.

XPFlightPlanner route finder, with the flight plan generator dialog
Routing options

In the routing options, you have the choice to connect your departure and arrival with the option “Connect departure and arrival to existing routes”. The flight plan generator finds routes based on existing database segment only. In the case this option is not selected and neither departure nor arrival is connected to an existing segment, the generator may not be able to find a suitable route. In the field “Search range” you may specify the range in nautical miles for connecting departure and arrival to existing database routes.

Then, you can choose the type of route to use. You have the option to prioritize High (JET) routes, use only high routes, use only Low (Viktor) routes, or have no preferences.

Route generation

Click the “Start” button to initiate the route generation process. Upon completion, the flight plan generator window can be closed and the resulting flight plan will be displayed in the main window.

In the event that the flight plan generator is unable to find a route, you have options to try again with modified settings such as connecting the departure and arrival to existing routes or increasing the search range for connections. You can also experiment with different route type preferences to expand the routing options.

Edit or create a flight plan manually

Flight plans can be created or modified either automatically or manually. The manual editing option also provides the ability to fine-tune an automatically generated flight plan, if you need to modifying the departure procedure as instance.

You can add waypoints to your flight plan in multiple ways, either by double-clicking a point on the map or a point in the navigation database list. To remove a waypoint, simply double-click it on the map. Right-clicking on a point opens a contextual menu with options to add the point to the beginning, middle, or end of the flight plan, or to remove it.

Manual edit the flight plan

Below the flight plan table, there is a compact toolbar that provides editing options for the flight plan. The options include the route generator (available when the flight plan has at least two waypoints), a button to add the currently selected point to the flight plan, a button to remove the selected waypoint, and arrows to change the order of waypoints, a button to reverse the flight plan order, and a trash button to clear the entire flight plan.

Open and save flight plan

XPFlightPlanner supports opening and saving flight plans in X-Plane’s native *.fms format. To open a flight plan, you can either click the button on the toolbar or select “Open” from the “File” menu. To save a flight plan, use the button on the toolbar or select ” Save” or “Save as” from the “File” menu.

To ensure the flight plans are found by X-Plane’s FMS, they must be saved in the <X-Plane>/Output/FMS plans directory. In the XPFlightPlanner preferences, you have the option to always open or save flight plans from this directory or to remember the last directory used.

Print a flight plan log

XPFlightPlanner allows you to print your flight plan log on paper for sim brief. To do so, navigate to the “File” menu and use the following options:

  • Page Setup: to choose the type of paper and orientation (Landscape or Portrait).
  • Print Preview: to preview the flight plan and check the paper settings before printing.
  • Print: to send the flight plan to your printer.
XPFlightPlanner print flight plan
Flight plan print preview

Note: For optimal readability, it’s recommended to set the paper orientation to Landscape rather than Portrait.

Load a flight plan into X-Plane

To load the flight plan into X-Plane’s FMS files must be saved in the <X-Plane 11>/Output/FMS plans directory.

To load a flight plan in X-Plane, follow these steps:

  1. Launch X-Plane and open the Flight Management System (FMS)
  2. In the FMS, click the ROUTE MENU button
  3. From the route menu, click the CO ROUTE LIST button
  4. The list of all saved flight plans will be displayed.
  5. Select the desired flight plan by clicking on its corresponding button.