Manual

Introduction

XPFlightPlanner is a simple tool for generating flight plans that can be used with X-Plane. It uses native airports, points and routes included in X-Plane’s world database.

XPFlightPlanner uses X-Plane’s native file format *.fms to store and load flight plans.

Remember, this tool must not be used for real world aviation but for simulation purpose only!

Installation and setup

XPFlightPlanner can be installed on Windows, Mac OSX and Ubuntu (see requirements on Download page). Installer files can be downloaded from here.

Installation on Microsoft Windows

To install XPFlightPlanner on Microsoft Windows, simply double click on the installer and follow the wizard.

Installation on Mac OS X

To install XPFlightPlanner on Mac OS X, double click on the image file *.dmg and copy the XPFlightPlanner application to the Applications directory.

Installation on Ubuntu Linux

To install XPFlightPlanner on Ubuntu Linux, unzip the *.zip archive anywhere. The application also runs on other Linux distributions, but Qt dependencies must be installed.

Register with your serial number

To register your copy of XPFlightPlanner go to the menu Help > Register.... Then, copy and paste your email and serial number from the email you received.

Be sure not to copy-paste extra characters like white-spaces etc. The fields are case sensitive.

If you did not receive your serial number by email, please check your spam folder. The email has been sent automatically upon purchase.

Updating the navigation data

By default XPFlightPlanner uses the navigation data provided by your current X-Plane installation. However, you might use an updated data cycle such as provided by Navigraph.

The updated data should be installed in the <X-Plane>/Custom Data folder, and must contain the following files:

  • earth_awy.dat,
  • earth_fix.dat,
  • earth_nav.dat,
  • CIFP directory.

After updated data cycle has been installed, launch XPFlightPlanner and open the preferences window. Check the box Use custom data, and then choose the path where X-Plane (with updated data) is installed; this path should be the directory that contain the X-Plane executable. Validate the preferences with the OK button and restart XPFlightPlanner.

XPFlightPlanner preferences window

Preferences window

XPFlightPlanner take a significant longer time to load custom data at startup rather than to load default data.

Using XPFlightPlanner

User interface overview

When XPFlightPlanner starts, the main window shows up; this window contains an empty flight plan document. This window is decomposed into four areas:

  • the flight plan table that contain the list of way points,
  • the map,
  • the flight plan vertical profile,
  • the navigation database with three tabs for:
    • points (FIX, VOR, NDB),
    • routes,
    • and airports.
XPFlightPlanner main window

Main window

The map, profile and database are “docked-windows” that can be hidden, moved or detached from the main window. The position of these docked-windows can be reset with the menu View > Reset panels.

Generate a new flight plan

Flightplans can be generated automatically or manually. When generated automatically a flight plan can still be modified manually.

Generate a flight plan automatically

XPFlightPlanner has a route planner that can find the best route from an aiport to another. Click on the toolbar button Automatically generate a flight plan or in the menu Flight plan > Generate... to open the flight plan generator window. Within this window you can choose:

  • The departure airport (and optionally the SID)
  • the arrival airport (and optionally the STAR/APPCH),
  • the plane performances based on:
    • your presets for keeping your preferred plane performances,
    • or custom performances.
XPFlightPlanner route generator dialog

Route generator dialog

When choosing a Standard Instrument Departure (SID) or a Standard Terminal Arrival Route (STAR) the flight plan generator will consider only this procedures for the departure an arrival airport. If no SID or no STAR is selected, the generator will choose the best procedure for each.

The plane performance settings have an influence on the routes chosen by the generator. The settings are:

  • During climb
    • Indicated Air Speed (IAS) in kts
    • Vertical Speed in ft/min (positive)
  • During cruise
    • Indicated Air Speed (IAS) in Mach or kts
    • Flight Level (FL) in hundred of feets
  • During descent
    • Indicated Air Speed (IAS) in kts
    • Vertical Speed in ft/min (negative)

Click the OK button to start the route generator. When the route finder algorithm is done, the generator window closes and the flight plan is displayed in the main window.

Generate a flight plan manually

Flight plans can be created or modified manually.

Points, routes or airports can be added to the flight plan directly from the navigation database. As instance (screenshot below), search for point XIKLA in the navigation database, select it and click the Plus (+) button from the toolbar to add it in the flight plan. The point can also be added by drag-and-drop from the navigation database to the flight plan.

A way point can be removed from the flight plan, select it and click the Minus (-) button from the toolbar as highlighted in the screenshot below. The way point can also be moved up or down using the arrow buttons highlighted from the toolbar.

XPFlightPlanner flight plan manual edit

Flight plan manual edit

Load and save

XPFlightPlanner can open and save flight plans in the native X-Plane format *.fms.

To open a flight plan, click on the open button from the toolbar or use the menu File > Open. To save a flight plan use the save button from the toolbar or the menu File > Save or File > Save as.

In order to be loaded by X-Plane’s FMS, the flight plans must be saved in the <X-Plane>/Output/FMS plans directory.

XPFlightPlanner can also export flight plans to Javier Cortes’s UFMC format. To do so, click on the menu File > Export to UFMC....

Print a flight plan

XPFlightPlanner can print the flight plan to paper. In the menu File use:

  • Page setup: to choose the paper type and rotation,
  • Print preview: to check the paper settings before printing,
  • Print: to send the flight plan to a printer.

The map can be removed from the page by unchecking the box Map is visible in the flightplan when printed in the preference window.

Load into X-Plane

To load the flight plan into X-Plane’s FMS files must be saved in the directory <X-Plane 11>/Output/FMS plans. Then run X-Plane, open the FMS and click on the “CO ROUTE LIST” button, all your flight plans will appear. To load the flight plan click on the corresponding button.

XPFlightPlanner import flight plan into FMS

Import flight plan into FMS