Download

Latest versions

XPFlightPlanner can be tested for free! Demonstration is limited to 5 waypoints.

Windows

MacOS

Ubuntu

 

XPFlightPlanner 3.0.4 for X-Plane 11

 

 

XPFlightPlanner 3 for Windows

 

 

XPFlightPlanner 3 for MacOS

 

 

XPFlightPlanner 3 for Linux

 

 

XPFlightPlanner 2.0.3 for X-Plane 10

 

 

XPFlightPlanner 2 for Windows

 

 

XPFlightPlanner 2 for MacOS

 

 

XPFlightPlanner 2 for Linux

 

Requirements

To run XPFlightPlanner you need:

  • Windows 7, 8 or 10 (32 or 64 bits)
  • Mac OS 10.10, 10.11 or 10.12 (64 bits)
  • Ubuntu 16.04 (64 bits only) [for other version of 64 bits linux, install Qt5.5.1]

Older versions

XPFlightPlanner 1.x customers can still download the previous version 1.2.8: